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1. Introduction
For some types of ERP experiments, the correction of ocular artifacts is necessary to obtain good average
ERP waveforms. This case study explains how this can be applied in the EEProbe signal processing
software. In this case study, we will use some standard pre-processing programs and use the interactive
viewers to classify, inspect the EOG events, and to assess their influence on the data. 

The procedures described apply to EEProbe version 3.2-4.

The example data as used in this document can be downloaded from

http://213.201.130.98/download/EEProbe/Examples/EOG/EEProbe-EOGcasedata.tgz
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2. Preparation

2.1. New Experiment
Before we start  the real work, you have to decide where the case study will be processed. From within
the EEProbe databrowser, you could use File → Create Project, or skip this and work in your default
project. 

Choose File → New Experiment and create the experiment “eog-testcase”:

Use the default options for New Experiment: create a cfg directory especially for this experiment, and
to copy the default configuration files from the project level. This restricts the use of the configuration
files to this experiment only and does not interfere with other experiments in the same project.

2.2. Install example data
The  example  data  that  will  be  used  in  this  case  study  is  available  in  the  file
EEProbe-EOGcasedata.tgz. Go to Tools → Install / Update as indicated below.

Perform the installation procedure by following figures  2 and  3, and install relative to the experiment
directory (“eog-testcase”).
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Figure 1. Create the experiment directory for processing the data of the case study.

Figure 2. Install the example dataset.



Click on the Install button; this unpacks the files koch01.cnt and koch02.cnt, containing two runs
of a typical auditory P300 measurement.

3. Preprocessing

3.1. Review continuous data

The files contains 30 EEG and 2 EOG channels, recorded at a sample rate of 256Hz. The data are already
referenced  to  the  'linked-ear'  reference.  Double-click  on  the  cnt file  in  the  Workset to  start  the
continuous data viewer. When reviewing the data, we can observe the triggers 1, 2 and 4 below the time
axis; these event codes correspond to the different conditions in an 'active' P300 paradigm, respectively
representing the 'standard', 'deviant' tones, and 'subject response'. 
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Figure 3. Select the compressed archive for installation.

Figure 4. Open and review the continuous data.



3.2. Filtering
The default  pre-processing includes filtering; we select  both data files in the  Workset,  and apply an
adequate filter by defining Highpass to 0.3 and Lowpass to 30 (Hz). You can use the ? button to read a
brief explanation on how the databrowser uses these settings to generate a FIR file.

Click the  Apply  button to start  the filtering process.  This  may take some minutes,  depending on the
speed  of  your  computer.  After  filtering,  the  output  files  koch01f.cnt and  koch02f.cnt are
automatically selected in the Workset, which you may review using one of the continuous data viewers.

3.3. Conditioning (optional)1

In order to obtain optimal average waveforms for both conditions, we want to perform the averaging on
all deviant trials only on correct trials. This means that we want to check on the correct response of the
subject, within a certain time window after the 'deviant' tone.

For this  pre-processing  step  we select  the  trigger  files  koch01f.trg and  koch02f.trg  that  are
associated with the  cnt files, and choose  Tools  → Condition / Trigger tools  → Trigger / response
validation. 

The Target and Response triggers should be set to 2 and 4 respectively, and we make use of the Inter-
Stimulus-Interval  criteria to  limit  correct  triggers  pairs  within  the  time  interval  of  150 to  800
milliseconds (see figure 6). We will change the target trigger code to 22 for the trigger pairs that meet the
'search criteria'.

1 For experiments where no response dependent averaging is performed, this step can be skipped. The trigger code
associated with the 'response' trials is then kept unchanged (in this case code '2' for condition 'deviant'). This
results in a different averaging configuration file for starting the EOG detection program (see section 4.2. Edit
configuration files).
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Figure 5. Apply a bandpass filter: use the Define option to automatically create a fir file (FIR
coefficients are calculated in the background, through the firfilter program).



After clicking the  Apply button, the trigger files are updated according to the above parameters.  The
corrected 'deviant' trials can be identified with the new trigger 22.

Use the  Tools → Condition / Trigger tools → Trigger count / ISI inspection tool to quickly review
the triggers as present after the conditioning step:

EEProbe - EOG correction case study Page 5 of 22

Figure 6. Recode the correct trials for the 'deviant' condition.

Figure 7. Review triggers using the 'trgcount' script (via the databrowser).



4. EOG classification
The EOG classification step should always be the last action taken before averaging. The  propagation
factors as needed for the correction (which is performed during averaging), are calculated for a specific
channel layout and will be invalid for data that is re-referenced to a different channel setup.

The EOG classification is performed interactively using the 'xeog' viewer program. This viewer can be
started  via  the  EEProbe  databrowser  in  its  'Classification  mode'  using  some configuration  files  (for
details, see the on-line reference manual). The databrowser will check some dependencies before actually
starting the program: the  trigger file  and the  rejection file. Both  need to be  present (having the same
basename as the cnt file). If the trg file is not found it will be created automatically using 'cntevents'
program; for a non-existing rej file an error message will be shown.

The EOG classification consists of two stages:

1. Prototype scoring, for which we have to perform rejection analysis, and
2. Trial classification, which depends on proper setup of your trial definitions.

Below, the paragraphs present the various steps in a logical order, as performed in practice.

4.1. EOG detection: rejection analysis
Before the EOG activity can be inspected, the data is scanned for the 'candidate' EOG events.  This is
performed using one of the rejection procedures as available via the EEProbe databrowser,  Analyze →
Reject  Continuous.  Start  this  analysis  with  the  output  file(s)  of  the  filtering  step  selected  in  the
Workset: koch01f.cnt and/or koch02f.cnt. You can choose to perform the rejection analysis only
on the first file, or on both files in one run.

The parameters for rejection as shown in this  dialog, specify that channels  Fp1 and  Fp2 are used to
detect  signal outliers using the “Standard deviation” criterion.  However, we would rather include the
EOG channels  of  the  current  data  set.  Follow the  steps  described  in  the  figures  below to  make the
detection specific to these channels.
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Figure 8. Start the "Reject Continuous" dialog.



The 'StdDev' parameter as entered here for the continuous rejection reflects the threshold value above
which the corresponding samples are marked as 'rejected'. For EOG channels a good default value for the
'StdDev'  parameter  would  have  been  30  μV,  however,  in  the  current  data  the  ocular  activity  is  of
somewhat smaller amplitude. A value of 30 results in EOG artifacts that are not marked completely by
the rejection intervals. Therefore we will use a more restricting boundary of 20 μV here. 

Select  the  option  Keep  changes  as  Default  Configuration (see  figure  8)  to  save  to  the  file
cntreject.cfg, which holds the rejection parameters for the current Experiment.

Now click the Apply button to start the rejection analysis. This will create a rej file for each cnt file as
selected.

You can review the results of the rejection analysis in the continuous data viewer 'xcnt' or 'qcnt' (double-
click on the  cnt file in the  Workset) to inspect the effectiveness of this procedure. Almost all EOG
related  activity  should  be marked in the data.  Use the arrow buttons  ◄►  for  Rejections  to quickly
browse the intervals marked as rejected (red line).

The rejection intervals as present in the file koch01f.rej (and koch02f.rej) are used as 'candidate'
EOG events, to facilitate the 'prototype scoring' as explained in one of the next paragraphs.

Note: In a different data set, if you had already performed a rejection analysis
at  this  stage  of  your  data  processing,  e.g.,  including  all channels  with  a
certain  threshold,  you can choose to  Merge new rejections with  existing
rejection  intervals (see  figure  8).  However,  you may end up  having  too
many 'candidate' events during the 'prototype scoring' step. 
If  desired,  you  can  also  perform  a  custom  rejection  process  later,  after
performing  the  EOG classification  (and  optionally  'merge'  with  the  EOG
rejected ). 

In  the  following  paragraph  we  will  first  prepare  for  the  'trial  classification'  by  defining  the  proper
relations for condition names and trigger codes.
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Figure 9. Click in the channel listing, and right-click
to select "Remove All" in the popup menu.

Figure 10. Enter 'eog=20' to quickly add the EOG
channels with a StdDev criterion.

Figure 11. Review the parameters for the two channels by clicking on the channel names.



4.2. Edit configuration files

Setting conditions: cntaverage.cfg
In order to display correctly the trials and conditions during the classification step, we must prepare the
default averaging configuration file cntaverage.cfg. This file is used by the databrowser to start the
'xeog' viewer. This configuration file must therefore contain the correct interval definitions, and should
hold all relations for trigger codes and condition names. With a cnt file selected in the  Workset, you
can start Analyze → Average.

The dialog as presented in figure 12 allows you to interactively create the required cntaverage.cfg
file. Define the condition 'standard' and relate this to trigger '1', and add condition 'deviant' for trigger '22'
(which is the trigger code after the response validation). After checking/setting the correct parameters,
select the option  Keep changes as Default Configuration and click on  Close. This will not start any
averaging process, but will save the cntaverage.cfg anyway.

If the conditioning step – response validation – is skipped, the 'deviant' code should be '2'.

Setting EOG parameters: xeog.cfg
Some important  parameters  for  the  EOG classification/correction  process,  as  well  as  parameters  to
control the user-interface of 'xeog', are specified in the  xeog.cfg file. This configuration file can be
edited via the EEProbe databrowser,  Analyze  → EOG Detection  → Edit Configuration. This menu
item is only accessible when you have one (not more) cnt file selected in the Workset.

The most important parameters are in the [eog channels] section; here you define the two channels
that are used to 'build' the prototype EOG events (by manual selection) on which the calculation of the
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Figure 12. Define the trials in the averaging configuration. Specify the condition names
and related trigger codes for all trials in which you may want to correct for EOG artifacts.



propagation factors is based. These factors define how the EOG activity is subtracted from the each of
the other (non-EOG) channels in the subsequent correction procedure. 

The default xeog.cfg file (as in figure 13) contains 'general' settings that will work in almost all (EEG)
data. This takes into consideration that not all measurements will include EOG channels, and therefore
specify the pre-frontal electrode labels Fp1 and Fp2 as 'EOG' channels. For a proper (optimal) correction
the inclusion of true EOG channels is much better, so please edit this configuration and use the following
parameters for the example data in this case study (shown are only the changed sections):

[eog channels]
HEOG, VEOG

[preview channels]
HEOG, VEOG, F7, F8, Cz, Pz

[channels]
HEOG     gray
VEOG     gray
Fp1      red
Fp2      red
F7       blue
F8       green
CZ       orange
PZ       magenta

[layout]
rows            3
columns         5
width         180    ; pixels
height        180    ; pixels
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Figure 13. Edit the 'xeog' configuration file to define the EOG channels, and to
customize the display layout.



As [eog channels] we will of course use the  HEOG and VEOG channels as present in the current
data set. 

The next section [preview channels] is optional: when left in comments (line starting with ';'), the
'average preview' (see  4.4. Trial  classification) will  show only the two EOG channels,  however,  it  is
much more useful to specify some additional channels here to 'preview' the effect of EOG correction.
When using this section, do not forget to delete the semi-colon ';' before the [preview channels]
header.

In the [channels] section, we also add the EOG channels. The channels in this sections will be used in
the 'block wise' display of trials and EOG events. Apart from the EOG channels, we also specify some
other electrode locations which we would like to (1) inspect for EOG activity and (2) check the quality of
EOG compensation.  Include positions  for instance far left/right,  on the central  positions,  or occipital
locations.

If the display resolution is high, you can change also the number of trials/EOG epochs that are displayed
together in the 'xeog' program. Change these details in the [layout] section. You may experiment with
slightly different settings here to create the optimal display layout on your computer.

4.3. Prototype scoring
When  the  configuration  files  as  described  in  the  previous  paragraph  have  been  checked,  the  EOG
Detection  → EOG/Trial Classification can be started from the  Analyze menu in the databrowser. In
contrast to almost all other procedures, this procedure only works for one cnt file at a time.

If the program does not start, you will probably see an error message in the console window from which
you started the EEProbe databrowser. This only happens when you have entered a wrong parameter, e.g.,
wrong electrode label, in one of the configuration files.  In this case, please review the procedures as
explained in the previous paragraphs.
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Figure 14. Initial startup of the 'xeog' program, showing the rejections 'block wise' for selected channels. The 'xcnt'
viewer shows all channels and is synchronized with the current selection by clicking in each cell.



The 'xeog' program shows you rows/columns of epochs corresponding to the intervals as defined in the
rejection file. As in the 'xcnt' program, the interface gives you control over Scaling of amplitude and time
(buttons ▲▼, ◄►), and using the Window buttons ◄► you can quickly browse through all of these
'candidate' EOG events.

The 'xeog' viewer can be used for Prototype scoring (step 1 as in Appendix A. EOG correction workflow)
and Trial classification (step 2) without having to restart the program. 

Depending on the selected entry in the Display menu, you are either in 'Prototype scoring' (top entries),
or 'Trial classification' (bottom entries).

Here we will first describe the prototype scoring, and leave the Display → Unclassified EOG Events
option as it is at the initial startup. 

During the manual selection of  prototypes you should include a number of representative 'Blinks' and
'Move' events. This selection can be made by clicking on the selection buttons 'U', 'B', 'M', to indicate
respectively 'Unclassified',  'Blink',  and  'Move'.  The  irrelevant  'R' button  ('Rejection')  is  not  available
during prototype scoring. 

The  scoring  should  aim at  including  the  'good'  blinks/moves.  Since  the  propagation  factor  sets  are
calculated from the prototypes, take into consideration that the selection made here greatly influences the
quality of the correction. Some general tips are presented below (also see the on-line reference manual):

➢ Don't use rare, very large 'blinks'. They are not typical and would dominate the factor estimation due
to their amplitude. At the other hand try not to use the small blinks even if they are frequent. They do
nearly not contribute to the factor estimation so you can save your time if you ignore them. A rule-of-
thumb is to include 20 to 30 'blinks'.

➢ The same is valid for 'move', but since good eye-movements are more rare than eye-blinks you may
have to use all you can find... You have to include at least 1 move prototype to enable the propagation
factor calculation. If you do not find any 'move', you may use any epoch of low amplitude, or use an
epoch where a rejection mark overlaps with only half of a 'blink' artifact. If there are not may 'move'
artifacts, you can omit the corresponding step in the next step (4.4. Trial classification).

➢ If  you  are  not  sure  initially  about  the  specification  of  your  trial  windows  (as  defined  in  the
cntaverage.cfg file, see 4.2. Edit configuration files), set a larger time range rather than a shorter
one. In doing so, your classification work will be valid in more cases. 

➢ Classify fast rather than careful in a first pass. In a second pass, the options  Blink Prototypes and
Move Prototypes in  the  Display menu  can be used to  review your  scoring in  the  corresponding
prototype classes. You will see the mis-classifications from the first pass very fast in the class context. 

Some examples for the scoring of 'blink' and 'move' epochs in the current data set are given in the figures
below. As described, you should select at least 1 'move', and approximately 20 'blinks'. 

In the diagram area you adjust and classify the epochs manually. If you prefer the keyboard to the mouse
you can select the current epoch using the keys <←>, <→>, <↑>, <↓>, <PageUp>, <PageDown>, and
classify  epochs  by  pressing  the  starting  letter  of  a  class  (e.g.,  'B'  for  'blink').  The  <Return>  key
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Figure 15. The Display menu controls the scoring/classification mode.



synchronizes 'xcnt' to the current epoch. Adjusting prototype epoch limits is possible with the pointer
only (left and right mouse buttons). Although this manual adjustment is possible, and may improve the
precision and thus quality of the prototype scoring, in most data it is preferred to leave the intervals as
defined in the rejection file. This file was created by the rejection procedure and is therefore easy to
reproduce, whereas any further manipulation of these intervals is subjective and just more work. 

Figure 16 shows two examples for 'blink' prototypes that were marked initially by the rejection process
for the full duration of the blink. The propagation factors are calculated from the data in the rejection
interval as indicated. Some other 'blinks' may not have been marked completely (see figure  14); do not
select these as prototype.

In the analysis as performed for this document, 20 blink prototypes and 4 move prototypes were selected.
The Status display will show the progress of the scoring (figure 18).

When you have scored a sufficient  number of 'blink' and 'move' prototypes,  select  Classification →
Calculate  Propagation  Factors in  the  menu.  You  will  see  that  the  Status now indicates  'Factors:
changed, valid'. Now make use of the 2nd and 3rd options in the Display menu (as in figure 15) to review
the  prototypes  by class.  As mentioned  before,  review here,  adjust  the  epoch  limits,  or  change your
scoring to 'unclassified' if  you find that  one or more of the prototypes should not be included in the
calculation. 

If you make changes to the prototype scoring, you again have to  Calculate
Propagation Factors (in the Classification menu).

EEProbe - EOG correction case study Page 12 of 22

Figure 16. Examples of blink prototypes.

Figure 17. Example move prototype. 

For detailed adjustment, the left and right mouse
buttons can be used to change the epoch limits,
between which the propagation factors are calculated.

Figure 18. The Status display shows the details on prototype scoring, factor
calculation and trial classifications.



Because the propagation factors have been calculated at this point,  the 'xeog' program also shows the
resulting  corrected  signals  in  the  display  as  a  dotted  line  (if  not  shown,  choose  Options  →
Show Correction). Use this to assess the quality of the EOG compensation: signal traces from electrodes
relatively far from the EOG electrodes should not show much change between the original and 'corrected'
trace (as is the case for channels Cz,  Pz – the two bottom lines orange, magenta). If necessary, enlarge
the amplitudes (or time scale) to enhance the display of the overlay of original and corrected signals.
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Figure 19. Review the blink prototypes.

Figure 20. Review the move prototypes.



Save the results
To conclude the prototype scoring step, save your work: 

1. The propagation factors are used during the averaging procedure (see Appendix A. EOG correction
workflow, file relations). It is therefore important to save these parameters to a pfc file. Choose File
→ Save Propagation Factors. The program asks for a filename: you should use the same basename
'koch01f' as in the name of the cnt file (see figure 22); this allows the 'cntaverage' program find
it automatically.

2. Also the  prototype scoring should be saved to a file. This file has  extension  cls and contains the
prototype classes as indicated for the 'candidate' EOG events (epochs as initially specified by rejection
file,  possibly  adjusted  manually).  Go  to  the  File  menu,  and  Save  Prototype  Classication.  The
program again asks for a filename; use the basename from the cnt file, to allow the 'xeog' program to
find it automatically when you want to review the EOG classification later.

4.4. Trial classification
The  next  step  in  the  EOG procedures  involves  the  classification  of  all  trials  as  predefined  in  the
cntaverage.cfg (see 4.2. Edit configuration files). During this step, you have to indicate which trials
will be corrected for 'blink' and 'move' artifacts. This classification is saved to the trigger file for use by
'cntaverage' (see Appendix A. EOG correction workflow, file relations).
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Figure 21. The File menu is used to save all work as performed during
EOG classification.

Figure 22. Save the pfc (and cls) file with the same basename as the cnt file, which is
indicated in the title bar. Type the basename in the Selection field.



To enter the trial classification mode, you do not have to restart the 'xeog' program, but simply go to the
Display menu and select Display → All Trials (or any of the other entries below – see figure 15). The
rows/columns in 'xeog' now show all  trials  together  with  the  time and condition  information (if  not
shown, choose Options → Show Legend). 

You can  go through all  of  the  trials  and indicate  manually  the  'blinks'  and/or  'moves',  however,  the
Classification  menu provides  some options  to  automate  the  most  common actions.  The  options  are
explained below. You may perform the actions presented in 1 to 3 as you read along, however, do not
perform option 4.

1. When using Sync Trials with Rejections, the program checks the trial rejection windows (as defined
in cntaverage.cfg) for overlap with rejection intervals and will classify the trial accordingly. This
action is performed at startup by default if no trial classification is found (from a  classified trigger
file, see below: Save the results).

2. The action Sync Trials with Prototypes checks the trial average windows (cntaverage.cfg) for
common time ranges with prototypes; it sets the classification of corresponding trials to the correct
prototype class as scored in the previous step. If a trial contains more then one prototype, the last one
is used.

3. Set Rejected Trials to Blink is the  option that saves a lot of time. Because  nearly all rejections in
trials are caused by eye blinks, you can better start with 'blinks' and reclassify within this class. After
selecting  this  option,  choose  Display  → Blink  Trials,  and  remove  the  (few)  non-blinks  (set
'unclassified', 'move' or 'rejected'). 

4. The option  Set Unclassified  Trials  to Move should  be used with  care.  The  rejection  process  as
performed by 'cntreject' (see 4.1. EOG detection: rejection analysis) usually marks only "large" EOG
events. You may find a lot of your trials infected by EOG but not marked as 'rejected'. You can either
leave these trials uncorrected – as would have been done before running the 'xeog' program – or go
through the data trial by trial manually and classify to 'blink' or 'move' for all such trials. If you do use
this option, all trials that would not have seen any correction previously will now be treated as 'move'.
You cannot harm much in applying the 'move' compensation to low EOG amplitudes, however, this
approach is not always valid.

In this  case  study action  1 has  no effect  at  this  point  in  the  case  study,  as  described  above.  When
performing action 2, you will change a few trial classifications, which can be seen in the Status change.
Next, perform action 3, and review using  Display → Blink Trials. 

You can undo the options 2, 3, 4, by selecting again option 1.

Save the results
After the trial classification step, save your work! Go to the File menu, Save Trial Classification, and
save  the  trg file.  For  the  koch01f.cnt file,  select  and  overwrite  the  existing  trigger  file
koch01f.trg;  the  classification  results  are  added to  the  file  to transform the  trigger  listing into  a
'classified trigger file'. The original trigger file contains three columns, the classified version contains
additional columns to indicate the 'unclassified', 'blink', 'move', or 'rejected' class. You can easily add the
trigger file to the Workset in the databrowser, and inspect its contents by double clicking on the file.
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Figure 23. Use the options from the Classification menu to speed
up the trial classification.



The classification as present in the 'classified trigger file' is  only used for  EOG Compensation, and is
only active when the corresponding option is used in the 'cntaverage' program. You can always revert to
the original trigger file (and undo changes from EOG classification or Conditioning) by selecting the
cnt file in the Workset of the EEProbe databrowser, and choosing Analyze → Extract Events in the
menu.

In 'xeog', the option File → Save Trial Rejections can be used to save a new rejection file (overwrite the
existing file) that reflects the new (reduced number of) rejections. This is optional and we do not use this
in the current case study.

4.5. Review classification results
When starting the EOG detection again for the same cnt file, the 'xeog' viewer will automatically use the
saved results, allowing you to review the prototypes and trial classification. The most important file in
this respect is the cls file, which holds the prototype classification. If you have this file (koch01f.cls
for koch01f.cnt in this case) you can quickly go through xeog's Classification menu, recalculate the
propagation factors, and perform the trial classification as explained in the previous paragraph.

A very useful tool to assess the quality improvement achieved by the EOG compensation algorithm, is
the  Options  → Preview Averages tool. Corresponding to the  [preview channels] section in the
xeog.cfg configuration file (see 4.2. Edit configuration files), you will be able to review the resulting
average waveforms  after EOG compensation (see figure 24). 

The Average Preview window shows the desired channels on the left, and the condition names on the
right. Resize the window to accommodate for the number of channels shown. Include a condition in the
preview display by clicking on its checkbox; the averaging may take some time for the initial display of
the average waveforms. However, then it allows you to interact much more direct: the average preview is
updated immediately when changing any of the trial classifications. This allows you to review in detail
the impact/improvement/deterioration of the correction in relation to the changes you make.

If you have made changes to the trial classification, do not forget to save the new 'classified trigger file'
via  File → Save Trial Classification.
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Figure 24. Average preview for selected channels in the current data set (negative plotted downwards).



5. EOG correction

5.1. Averaging
After performing all steps as explained in the EOG classification chapter, we can calculate the EOG-
corrected averages for the P300 data as available for this case study.

Select the koch01f.cnt file in the Workset, and start Analyze → Averaging...

The parameters  shown in  the  CntAverage dialog come from the  default  cntaverage.cfg file  as
created in  4.2. Edit  configuration files. The parameters are already correct  for the trial  windows (the
three entries at the top), and specify the correct  Conditions. Because we have created the propagation
factor (pfc) file and have a classified trigger (trg) file, we can now use the EOG Compensation mode.
Perform the averaging  On EOG channels in  order  to  see  how well  the  EOG  signals  are  corrected.
Ideally, the correction should suppress most or all EOG activity (e.g., see figure 24).

We will perform the averaging twice, to allow inspection of the influence of EOG correction. For the
first run, when using the EOG correction,  set the  Output path to 'eogcorr' (see figure  25). This means
that the 'cntaverage' program will create the subdirectory 'eogcorr' in the Subject directory. You should
see a Command Output window showing messages similar to this:
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Figure 25. Start the averaging procedure with EOG compensation enabled.



For the second run, select again the koch01f.cnt file in the Workset, go to Analyze → Averaging.
Now do not use the EOG Compensation, and set the Output path to 'nocorr' .

5.2. Review
To view the averages resulting from the above processing, select all output avr files in the Workset, and
press <Enter>, or select View → Average. Right-click on the diagram showing the Cz channel, Zoom in
and you can see the effect of averaging with and without EOG compensation.
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Figure 26. The output of the current averaging procedure shows the applied EOG
compensation as 'b' and 'm' for the corresponding blink and move trials.

Figure 27. Display of Cz-average for corrected (solid line) and uncorrected waveforms (dotted line).



6. Additional notes

6.1. How to re-use propagation factors (within subject)
The example data for this case study contains another file measured in the same subject, using a similar
P300 protocol.  Since this  measurement  –  koch02.cnt – was performed in the same conditions,  an
obvious question that arises is: how can we reuse the propagation factors for the averaging of this second
file?

Still the best procedure would be to go through all of the steps as described in this document. However, a
quick way to reuse the work as performed for the koch01f.cnt file is the following:

1. Perform all procedures as explained in chapter  3. Preprocessing and paragraph  4.1. EOG detection:
rejection analysis for the new file koch02.cnt

2. Start the 'xeog' program through Analyze → EOG Detection → EOG/Trial Classification

3. Perform the Classification → Set Rejected Trials to Blink as explained in 4.4. Trial classification

You will not be able to preview the result of the correction (signal overlay of dotted
lines – see page  13), because we do not have a  cls file associated with the current
koch02f.cnt data file2. Even if we copy the pfc file as explained below, the preview
will not be available because the propagation factors remain invalid without a cls file
(see Appendix A. EOG correction workflow, file relations for file dependencies).

You can inspect the Blink Trials (from the Display menu) and quickly browse and change the trials
that you think should not be included for EOG compensation.

4. When done, save the 'classified trigger file' koch02f.trg, and quit the 'xeog' program

5. Copy the pfc file to the new base name, as explained in the figures below:

Now you can perform the averaging procedure exactly as explained in chapter  5. EOG correction.  The
improvement from the EOG Compensation in the averages of this second data file is more dramatic on
the P300 waveforms than in the first file, as illustrated in the 'xavr' display (figure 30):

2 The only way to preview the correction without creating a new prototype classification for koch02f.cnt is to
concatenate the file koch01f.cnt (for which we have the prototype classification koch01f.cls) and
koch02f.cnt to output.cnt, and copy the cls file to the same basename output.cls. The concatenation
can be done using the EEProbe databrowser: select both files in the Workset, and go to Tools → Continuous
data management → Concatenate files. Switch on the option to Use external trigger files to include the
results of the Conditioning step. You also have to create the associated rej file: perform the rejection procedure
as in 4.1. EOG detection: rejection analysis. Now go to step 3 on this page.
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Figure 28. To copy the pfc file to reuse it for
another data file: select and right-click on the
pfc file and select Copy from the popup menu.

Figure 29. Type the name of the destination
pfc file (same basename as cnt file).



6.2. How to create an EOG-corrected cnt file
For some research purposes it may be necessary to review the EOG-corrected cnt file. Also for certain
(external) single trial procedures this continuous data file may be required.

As part of the EEProbe programs are available two converters: 'trials2bin' and 'bin2cnt'. 

The first converter will build the trials from the cnt data, using the configuration and input files exactly
the way 'cntaverage' would do before the summation/averaging, including baseline correction and eog
correction steps. The output filenames (one file per condition) are built analogous to the conventions of
'cntaverage', creating bin files (custom binary format, see the on-line help manual). 

The second converter can import the custom binary format to the compressed riff cnt format.

The following utility can be downloaded from the EEProbe download web-site3: 'trials2bin2cnt'. This
downloaded  tgz file  can be installed via  Tools  → Install  /  Update  → Install  Program / License
(install relative to the project directory). The script/template is then immediately available via the Scripts
menu: choose its Edit option to arrive at the following dialog window:

The 'trials2bin2cnt' template conveniently combines the use of the programs 'trials2bin' and 'bin2cnt'.

3 http://213.201.130.98/download/EEProbe/scripts/trials2bin2cnt.tgz  
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Figure 30. Signal improvement through EOG correction in the koch02.cnt file.

Figure 31. The dialog for the script/template 'trials2bin2cnt'.



Short usage description
Using the  default  options  (as  shown in  figure  31)  will  create  a  cnt file  for  each  condition  in  the
subdirectory  export1. The output files will contain discontinuous data as indicated by 'discontinuity
triggers' (see figure 32).

The script will automatically find the cntaverage.cfg file in the appropriate cfg directory relative to
the  subject  directory. Select  the  cnt file  in  the  Workset before  going to  the  Scripts  → template:
trials2bin2cnt. The required pfc file, and (classified) trg file should be present for the selected cnt
file.

Optionally you can have the script  change the  trigger  codes to  the  condition labels by selecting the
corresponding checkbox in the dialog.

6.3. Using the results of different rejection procedures
One may argue about the EOG classification/correction procedures as explained that the process in 4.1.
EOG detection: rejection analysis does not include all channels and therefore will miss some artifacts. 

This  little  drawback can be overcome by performing again the  rejection  analysis,  now including the
desired  channels4.  You may use  the  option  Merge  new rejections  with  existing  rejection file (see
figure 8, page 6) to make sure that you keep the rejections for EOG channels. However, this is not strictly
necessary when the classification file cls was already created.

With the newly created rej file, start Analyze → EOG Detection. Probably there will be more rejection
intervals than before, however, xeog's  Display → Rejected Trials will not show anything because the
'classified trigger file' overrules the rejection file. To include the new rejections you should go through
the steps 1 to 3 (and optionally 4) as explained on page 15.

Now you should review with more care the signals as presented by Display → Blink Trials since more
trials (possibly not contaminated by EOG artifact) will have been marked by the rejection procedure.

4 If your measurement contains a 'bad' channel, you probably have to exclude this from the list of Channel
Thresholds, otherwise you may end up with all trials rejected. Bad channels may be interpolated in the avr file.
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Figure 32. Exported cnt file for the 'standard' condition trials.
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Appendix A. EOG correction workflow, file relations
Procedures 1 and 2 are performed interactively using the xeog program, procedure 3 is performed by the cntaverage program.
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